loss of power

Joined
Dec 10, 2007
Messages
9,810
Reaction score
3
Location
Hemel Hempstead
starting to get fed up of driving the v6 now, feels like its getting worse every day, basically i fell like i have lost alot of power in the engine since i first got it 1,2,3,4 gear there is no pull what so ever like there used to be, i know v6's are slow of the mark and better on the top end but it just feels like a 1.8 engine.

i think the exhaust is slightly blowing, im looking at getting a new system made up, i dont know what els to check really everything looks fine on inspection.
 

rickisgrate

Administrator
Club Staff
Regional Co-Ordinator
Club Member
Joined
Oct 20, 2005
Messages
22,980
Reaction score
189
Location
kilmarnock
i had the same problem if you remember just before xmas with a loose wire going into the ECU wiring loom, have a check there as well
 

rickisgrate

Administrator
Club Staff
Regional Co-Ordinator
Club Member
Joined
Oct 20, 2005
Messages
22,980
Reaction score
189
Location
kilmarnock
Also ive found the throttle body is really bad for gunging up on the v6's give it a clean out as well and see if it helps any, last time i cleared mine it made a hell of a difference
 
Joined
Dec 15, 2007
Messages
6,187
Reaction score
57
Location
Norwich
Hey, enough of the 1.8 slating :tape::lol:

On my C18XE i had a similar problem mate, did my head in for ages and kept getting worse, felt like fuel starvation, so changed the fuel filter, fuel pump, spark plugs, leads etc etc etc.

In the end i was at a scrap yard and decided to pocket a fpr from a Veccy x20xev, and thought what the hell ill swap it. And it was back to normal after that :nod:

Worth checking mate, it was the last thing i thought it would be :beer:
 
Joined
Jun 19, 2008
Messages
416
Reaction score
0
Location
Devon
Check the ignition module mate as if it knackered or you have loose wires it could cause loss of power
 
Joined
Jun 19, 2008
Messages
416
Reaction score
0
Location
Devon
yeah the engine loom is not the best tbh, in the past someone has cut and crimped it to extend the wires all needs stripping back, but thats a right pain in the ass :P
Try swapping the complete loom over for one that hasn't been butchered mate,i might know someone who has one if you are interested
 
Joined
Jan 1, 2008
Messages
207
Reaction score
0
Location
Northampton
not sure if it's any use but i do have a complete x25xe ignition/injection system and will have a spare ecu in a couple of weeks, not sure if it will be the immobiliser type or not though
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top