mk3 1.4 astra si electrical prob- alternator?

Joined
Jan 12, 2010
Messages
41
Reaction score
0
hi guys, 1st thread, hope you can help.

out of nowhere, my alternator belt started squelling, then when listening to a cd- cd player would turn off and back on continually. having a gte digi dash fitted i have voltmeter reading (usually 15 16volts running). now heres the wierd bit, i turn n the heater, fan speed 1 and 2 are now temprementle but 3 always works but when on i loose my revometer? battery voltage keeps dropping to 12v running, and at night when lights on barely runs at 9v.

could this all be due to alternator? how could i test it if so. if not does anyone know of any common faults?
 

Andy_Mk3

Administrator
Club Staff
Club Member
Joined
Apr 10, 2008
Messages
39,579
Reaction score
738
Location
Lincolnshire
Sounds like your alternator yes. Best thing to do is test the output with a proper multimeter. First with the engine running and nothing electrical switched on, it should be around 13.7 to 14.4v, certainly not 15 or 16v. Then do the same with everything on, heater, headlights, heated screen etc.. you should still get about the same voltage, although not lower than 12.5 under load.
 
Joined
Jan 12, 2010
Messages
41
Reaction score
0
hi yea sorry, voltage was 14v on the dash not 16v. tester it earlier today. alternator fine, however found that my alternator bracket had snapped, leaving an earth lead terminal from the engine loom snapped and the alternator belt loose. £10 from a scrappy soon sorted it, cheers everyone!!
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top