Want to remove ads? Become a MK3OC Club Member today!

strange one for you guys... LET reving itself

Joined
Mar 15, 2008
Messages
5,314
Reaction score
18
yer this is a bit of a strange one guys...

its on a C20LET running phase 2 chips on standard management/turbo etc...

after a bit of "spirited driving" yesterday i pulled up to a roundabout and when i dipped the clutch i herd the enging rev itself, when i looked at the rev counter to see what it was doing it started pliping the throttle every time the revs hit 1k, just enough to get the revs up to about 2.5k and then they would drop down till it hit 1k and did it again

had no EML up on the dash

it kept doing it until i turned the engine off and back on again and then it stopped, and it hasnt done it since.

anyone had this or know what could have caused this?
 
Joined
Apr 20, 2009
Messages
1,894
Reaction score
0
Location
bristol
my car dose this and its could be one of 2 things i ve been told and thats is throttle position sensor or the icv but i have an ecotec and not sure if it could be the same on the let but it could be im sure some one will be along to confirm or correct mate
 
Joined
Mar 15, 2008
Messages
5,314
Reaction score
18
yer id normaly say ICV but it only did it that once and since turning the engine off and on again it hasnt dont it at all.

thats whats strange :doh:
 
Joined
Aug 18, 2006
Messages
3,620
Reaction score
2
Location
sheffield
my old astra did this it was cured by cleaning the icv out
 

Users who are viewing this thread

Top